OAuth2 authorization flow no longer working

An Oauth2 authorization flow that worked before, stopped working. requestCredentials triggers an auth window, but that simply displays the same macro, not the authorization flow.

This is the code that triggers the flow:

const github = api.asUser().withProvider('github', 'github-api')

if (!await github.hasCredentials()) {
   await github.requestCredentials()

We implemented several providers that all worked before, they now all simply show confluence with the same macro in the auth window.

For users that succesfully authorized before, hasCredentials returns true and the macro is working and showing the result of an API call.


Hi @g.j.streek, we noticed problems with authentication in Forge. I requested the relevant team to resolve this issue. Thank you for reporting it.

Hi @g.j.streek apologies we didn’t communicate in this thread.
There is a fix provided in here Forge app stuck in configure access loop - #8 by ChrisWilliams

We are also rolling out a fix for this soon.

This fix is now rolled out. We expect the issue to be fixed without the above quick fix.

If anyone is still facing this issue please let us know.

Thanks for the update @JoshuaHwang