Old Jira rich editor in my plugin instaed of new rich editor

I want to use the new Richtext Editor in my Plugin, but I get the old one, with a bug (It shows the Text above the blue Icon) a second time. If I disable the new Richtext Editor, the old Editor is rendered ok.

I’m using Jira Core 7.3.6.

Here you see what I get and what I expect.

Thats my code:


A Context Provider where I add the rederer descriptor:
JiraRendererPlugin renderer = ComponentAccessor.getRendererManager().getRendererForType(“atlassian-wiki-renderer”);
JiraRendererModuleDescriptor rendererDescriptor = renderer.getDescriptor();
context.put(“rendererDescriptor”, rendererDescriptor);
context.put(“rendererParams”, Maps.<String, Object>newHashMap());

And my .vm file where I add the RichEditor:
!rendererParams.put("rows", "5") !rendererParams.put(“cols”, “35”)
$!rendererParams.put(“wrap”, “virtual”)
$rendererDescriptor.getEditVM(“Test”, “null”, “atlassian-wiki-renderer”, “responsible”, “responsible”, $rendererParams, false)

I am experiencing the same problem for my plugin on different JIRA Software versions (7.0.0 - 7.4.2). To fix this would be very helpful.

I experienced the same problem while trying some sample plugin. Though I could not find a solution and just left it, this might be of some little help to someone:

It seems there are some CSS/JS files responsible to adding the “Text” / “Visual” Tab that harald.ratzberger has shown in the image. Those files for some reason do not load. There are no exceptions or any reason anywhere for this, but a lot of CSS/JS files like editor-toggle.css, wiki-rederer-override.css etc. responsible for the correct functioning of the Rich Text Editor just do not load.

Also, I experienced that for a few minutes the Rich Text Editor did work nicely (all the files loaded), but a few refresh later it stopped. I could not find a reason why this would happen, may be someone can shed more light on it and help.

1 Like

Hey there,

with JIRA 7.2 you need to enable the rich text editor in the System Configuration before you can use it. You can find it right there:

Just activate the editor and you are ready to go.

I recommend you to use it with JIRA 7.3 and above, I believe there is still a bug in JIRA 7.2

I think in the original question, its mentioned that the RichText Editor is Enabled.
The problem is actually that once you enable, things start misbehaving for eg. the first image posted by herald.ratzberger. If you disable the RichText Editor the old Wiki Editor takes over and that works fine.

Thank you for your answer, but my RichText Editor is enabled. It works on the issue view, but not in my own plugin. Regrads, Harald

Late answer but maybe someone could still find this useful.

Add this line to your velocity template:


and everything should work.


I got the same problem like harald.ratzberger, I created a new view as a velocity and tried to use the editor but I got the editor with the bug.

The required Resource is the solution to get the new editor, but I acctually used the PageBuilderService


Many thanks @markus.neubauer

Thank you @markus.neubauer, this solution solved our problem with not loaded visual editor.

Thank you @markus.neubauer, that solved my problem :ok_hand: