openCreateIssueDialog - Create issue dialog - field got unaccessible to enter anything

Hi,

We are using AP.jira.openCreateIssueDialog to open jira issue create dialog from my cloud app.
When I have open any modal-dialog inside my app, at that time if I try to open jira issue form (openCreateIssueDialog) from either left side “+” button or through “AP.jira.openCreateIssueDialog”… it’s open properly but not able to fill any value inside that form… that overlay become unresponsive… ( summary field, description not able to type anything inside that form )

Is there any problem with modal-dialog css override or with openCreateIssueDialog css override issue?

1 Like

Hi @umang.savaliya,

I’ve tried replicating this inside a generalPage module and triggered the AP.jira.openCreateIssueDialog and was able to fill in and create new issue. Which module are you encountering this issue?

Cheers,
Anne

Hey @acalantog,

Pls try with below step to reproduce this issue…

  • Jira cloud AddOn
  • We have ReactJS + atlas kit Component
  • In our gernealPage → We are opening one atlas kit modal
  • Now open JIRA issue create overly ( now we have two way )
    ** Programmatically from addOn we can open this dialog using AP.jira.openCreateIssueDialog
    ** Or user can go to left blue panel where we have “+” blue round icon and try to open issue overlay from there.

Thanks,
Umang

1 Like

After updating several atlaskit modules, I have the same problem… Can’t figure it out, how it could be connected. Did you manage to find the workaround?

[EDIT] Wow, I was able to fix the problem with parameter added to atlaskit dialog: autoFocus={false}

1 Like

Unfortunately, Create modal still sometimes is broken, the problem is rare but still occurs and is unpredictable. I guess I will have to get rid of Atlaskit modal…

I have figure it out. Everything because of
import ReactFocusLock from ‘react-focus-lock’;
used by Atlaskit modal-dialog in version > 6
In newest modal from atlaskit focus-lock keeps the focus on modal that is underneath the Create Issue modal. There are 2 workaround for that: 1. close your dialog before opening the Create Issue modal. 2. Change the stackIndex prop - Number representing where in the stack of modals this modal sits. This offsets the modal dialogs vertical position.

After analysing the source code of Modal we can learn that Focus lock is enabled only for the first modal in stack (which makes perfectly sense)

<FocusLock
    isEnabled={stackIndex === 0 && isOpen}
    autoFocus={autoFocus}
>

Happy coding!

1 Like