Osgi.extender - Unresolved requirements


I am getting this error when building my plugin for Confluence 7, it builds ok for Conlfuence 6.

Getting this error
osgi.extender; (&(osgi.extender=osgi.component)(version>=1.3.0)(!(version>=2.0.0))) Unresolved requirements

Any hints or directions are very welcome.

Did you ever solve this problem? I am having the same issue.

The provided error message is just too short. The error says: Something cannot be resolved. Likely some dependency problem.

In case anyone else stumbles upon this, I just ran in to the issue again with another one of my plugins after previously forgetting how I fixed it. So now I am writing it down!

I encountered this error when I upgraded AMPS to 8.0.x and it was extremely frustrating because yes, the error message is too short and if you Google it, you find all sorts of different suggestions that lead you down a rabbit hole and into a drinking problem. (Or is that just me?) Anyway, it was finally solved with a very simple change:

In two of my classes I had used the @Component annotation for AMPS 6.x, and that worked fine but for whatever reason it threw this weird error in 8.0.x. I changed @Component to @Scanned and now everything is working properly again.

1 Like

With recent AMPS and atlassian Spring scanner, it is recommended to use only javax.inject.Named and javax.inject.Inject annotations.
Please review details at: https://community.atlassian.com/t5/Jira-articles/Spring-Java-based-configuration-and-AOP-in-Jira-plugins/ba-p/762265