Passing a file from form to webwork action

I am working on a plugin that requires me to be able to parse an uploaded file - I have created a configuration screen for a plugin that has a small form on it with only input for the file. The thing is, I have no idea how to get the file that user puts into this form once I am inside the Java webwork action class. I have been able to pass variables from form to Java as Strings or numbers, but I havent been able to figure out how to obtain the file.

My .vm file

    <form class="aui" method="post" action="secure/admin/SpiralImporter.jspa">
            <legend><span>File upload</span></legend>
            <div class="field-group">
                <label for="file-upload-example">Upload file</label>
                <input class="upfile" type="file" id="fileImport" name="fileImport">

        <div class="buttons">
            <button id="submitForm" class="aui-button aui-button-primary">Save</button>

I have a Java class for the action, which gets called correctly.

public class SpiralImporterAction extends JiraWebActionSupport {
    private File fileImport;

    protected String doExecute() throws Exception {
        //this gets called, but the variable is empty

    public File getFileImport() {
        return fileImport;

    public void setFileImport(File file) {
        this.fileImport = file;

I have tried accessing the file through the MultiPartWrapper as is shown here, but it seems to be empty when I submit the form

MultiPartRequestWrapper wrapper = (MultiPartRequestWrapper)ServletActionContext.getRequest();
File file = wrapper.getFile("fileField");

I have also tried the solution shown here, but it all comes down to the fact that there seem to be no file passed through the request.

Is there some way around it? Or some simpler way to let the user upload a file I could parse and take some actions based on its contents?

Just to be sure,
Did you try File file = wrapper.getFile("fileField");
File file = wrapper.getFile("fileImport"); ?
I believe it should be the later based on your .vm file

Yea that is a copypaste error, but it fails on this line anyway because wrapper is null.

I think you missed this encrypt details.

  <form action="/secure/testmethods.jspa" method=POST class="aui jim-form" enctype="multipart/form-data">

Did you find the solution finally?