Plugin com.atlassian.maven.plugins:maven-jira-plugin:8.0.2 or one of its dependencies could not be resolved


I am trying to build our custom plugin for jira. When I run atlas-run CLI command, I get the following error.

The following are the parameters for my plugin :
Jira version : 8.2.3
Amps version : 8.0.2


Amps v8.0.2 uses artifactId “jira-maven-plugin” for “com.atlassian.maven.plugins”. But the error is quite weird that it tries to download “maven-jira-plugin” for version 8 from the repository.

[ERROR] Unresolveable build extension: Plugin com.atlassian.maven.plugins:maven-jira-plugin:8.0.2 or one of its dependencies could not be resolved: Failure to find com.atlassian.maven.plugins:maven-jira-plugin:jar:8.0.2 in was cached in the local repository, resolution will not be reattempted until the update interval of atlassian-public has elapsed or updates are forced @
[ERROR] The build could not read 1 project -> [Help 1]

Any help is greatly appreciated!



with version 8 of AMPS, they changed the plugin names. Look for references to maven-jira-plugin in your pom.xml and replace them with jira-maven-plugin.



Hi @tobitheo,
Thanks for the reply!

I am using “jira-maven-plugin” for AMPS 8.0.2 (Please see my plugin for jira-maven-plugin in my initial question). This is the only reference I can find in my pom. But somehow, when I try to run it is picking “maven-jira-plugin” instead of “jira-maven-plugin”.


Hi Kumar,

have you tried a atlas-mvn clean since the change? Sometimes old build artifacts are still hanging around in the target directory and that kills them. Then try atlas-debug again.

The other thing I can think of is if one of your dependencies is still using the wrong plugin (or if you have a multi-module project where the parent pom or one of the siblings are still using the wrong plugin).


Hi @tobitheo, yes, the parent pom dependencies are still using old artifacts. Thank you!

That’s great to hear! Would you be so kind as to mark my above message as a solution to this topic please? It helps others with the same problem find the solution more quickly and gets me some nice bragging rights :wink:


1 Like

The first time I run my plugin with atlas-debug or atlas-run it starts without problems, but when I stop the server and run atlas-run or atlas-debug again I get the same error as a @klkumar143

Thanks, Hector

Thank you!
It helps me