Receiving JQL error on date

Received the following from a query to /rest/api/3/Search

{“errorMessages”:[“Date value ‘2021/03/28 01:09’ for field ‘updated’ is invalid. Valid formats include: ‘yyyy/MM/dd HH:mm’, ‘yyyy-MM-dd HH:mm’, ‘yyyy/MM/dd’, ‘yyyy-MM-dd’, or a period format e.g. ‘-5d’, ‘4w 2d’.”],“warningMessages”:}

2021/03/28 01:09 seems compatible with yyyy/MM/dd HH:mm

Started happening on 3/27 at 6PM PDT (3/28 1am UTC).

Here is a shorter form of the query with the same error.

It works if I remove the hours and minutes

1 Like

Hello, were you able to fix this problem?
I have the same problem with JQL but different date. Posting “jql”: “Updated >= ‘2021-03-14 02:30’”
returns the same error.
For 2021-03-14 01:59 and 2021-03-14 03:00 works fine. From 02:00 till 02:59 - fails.

Hi @MarkDavies and @BoYaroslav,

I have attempted to replicate the behavior in my test instance where I only have one issue that has been updated recently. Using the same REST API call shared in your message, I was able to collect the results correctly.

Could you confirm if you are still affected by this problem?

Rodrigo Heinzen