Recently i am getting this error 'jsx is not defined' and I have no idea why

I have a force UiKit app which worked perfectly for the last month or two but then suddenly one other colleague noticed that it gives him this error:
when he navigates to the app.
I tried to open the app and the same error occured.
I have changed nothing in the code or the environment.
Any suggestions about why this could happen?

P.S. I have no ‘jsx’ variable in my code
This is the error in the console:

shared~vendor~ar.c940ce48.js:1 ReferenceError: jsx is not defined
at n (date.1f7b38b2.js:1:2336)
at o$ (shared~vendor~ar.c940ce48.js:1:64932)
at u (shared~vendor~ar.c940ce48.js:1:130020)
at l_ (shared~vendor~ar.c940ce48.js:1:114381)
at shared~vendor~ar.c940ce48.js:1:114159
at lv (shared~vendor~ar.c940ce48.js:1:114167)
at lu (shared~vendor~ar.c940ce48.js:1:110889)
at iR (shared~vendor~ar.c940ce48.js:1:48732)
at shared~vendor~ar.c940ce48.js:1:108280


Same Problem here! Since today.
The app with problems uses UI Kit 1 and Typescript.

1 Like

jsx is going to likely be coming from React. It’s possible it was updated to a minor version in the background or something like that, which was triggered on a redeploy or something of the sort. Would it be a large effort to move to UI Kit 2? Moving the npm packages off of deprecated versions might solve it.

Hi @AaronCollier,
yes it sounds like a problem with react, likely with Atlassian moving things forward with the new UI Kit. There was no deployment from our side since the issue occored this morning and no warning or deprecation announced by Atlassian. We are in contact with them and they are working on it.
We already tested updating all npm packages with no change in the error response.
Moving to UI Kit 2 is on the roadmap, but not something you want to rush with an established and complex app that has more than 7000 lines of code.

1 Like

Hi @DanielVelkov,
I do believe to have found the root cause.
It is the UI Kit 1: DateLozenge component. Comment out all instances of this component and the app will work again. I also informed Atlassian, and hope they can resolve this incident soon.
Best regards, Wolfgang

1 Like

Hi @DanielVelkov

Thank you for posting.
Our dev team has identified the issue and a fix is already in the pipeline.
The issue should be fixed soon.

Feel free to reach out to develoloper support team if you’d like more details.

With Regards, Nashid

1 Like

Thank you so much. This fixed my issue.

1 Like


We would like to inform you that the fix has been implemented in all production environments and the issue should no longer appear.

Best Regards, Mirek.

1 Like