Refresh token is missing in response

I was implementing OAuth 2.0 from this article and encountered an issue with obtaining refresh token. I`ve found some tickets in the community about this topic, but none of them helped me to resolve my issue.

I`ve added offline_access scope to request to /authorize endpoint , and now my url looks like this

https://auth.atlassian.com/authorize?audience=api.atlassian.com
&client_id=my_client_id
&scope=read:me%20read:account%20read:jira-work%20read:jira-user%20read:servicedesk-request%20read:servicemanagement-insight-objects%20offline_access
&redirect_uri=my_callback_url
&state=Z838926.34:51:31T72-30-42029310cc0db380-99d8-b8d4-15e4-1fa5cd1a:020217
&response_type=code
&prompt=consent

but even after receiving authorization code and exchanging it to access token
my response only contain access_token

Can someone please assist in this manner

I`ve tried doing as @ibuchanan suggested in this comment

but unfortunately it didn`t help

@AdriianSemotiuk,

Thanks for sharing my response here. I can’t offer any further diagnostic advice. This might be better handled by developer support because the next steps probably require sharing some of the details about your app like the client id, and maybe looking into our back-end logs.

I`ve fixed that just by creating new Oauth 2.0 App in developer console and for the new one it worked just fine

1 Like

@AdriianSemotiuk,

Glad you found a quick and not-too-disruptive workaround. Still it’s strange that it happens at all! I hope it’s so rare that you never see it again.

1 Like