Registering a Jira add on

We are currently developing an addon for Jira Cloud ( It worked well for several days then it stopped working on Jira with this error message (see log output below): Installation verification error: 401 clientKey in install payload did not match authenticated client

node -r esm app.js

Failed to register with host (200)
The app host returned HTTP response code 401 when we tried to contact it during installation. Please try again later or contact the app vendor.
{“type”:“INSTALL”,“pingAfter”:300,“status”:{“done”:true,“statusCode”:200,“contentType”:“application/vnd.atl.plugins.task.install.err+json”,“subCode”:“”,“errorMessage”:"The app host returned HTTP response code 401 when we tried to contact it during installation.
Add-on not registered; no compatible hosts detected

Would you help explaining the problem and how we can proceed?


Hi @MaldaElChalakAdmin ,

It seems like your app is based on Atlassian Connect Express, since it matches the error reported on this line.

My guess is that something changed in your app’s configuration or its datastore such that it can’t look up the installation information it saved during a previous installation.



Hello Dugald,
thanks for your fast response. Yes the app is based on Atlassian Connect Express. The original changes - after which it stopped working - were smaller changes inside the addon and not part of the configuration. Do you know how the clientKey is set or calculated or how to get more information why it fails?

Thanks a lot in advance.

Shot in the dark: Did you upgrade your app to handle the QSH thing and make a mistake?


Since you’re using ACE - what’s the db you’re using?

If you haven’t changed it - it’s the in memory (or at least it used to be). If that’s the case - a restart would cause the shared secret be wiped and any subsequent installs be rejected. If that’s the case - uninstall it manually from Jira and then attempt to install it again.


I got it working again after resetting up the environment. The tip from @mararn1618 was very likely the reason for it.

Thanks everyone for your support.

1 Like