Removing scopes in manifest causes apps not to work anymore

We wanted to create cross-platform app. That is highly encouraged by Atlassian as you can read here -

Forge as a platform supports and encourages developers to build apps that are compatible with multiple products.

Both jira and confluence scopes in manifest it all worked fine when you could install apps via CLI. If both Jira and Confluence has apps installed it showed great success. Thus all test passed and it was time to release it. Then of course the truth came out that even when you can internally do it, then marketplace does not support it. Opposite to what has been said in forge docs at

Thus forge app was deployed to production, but now we had to do rollback. Removed jira scopes and left only Confluence ones.
AND now you cant anymore enable app. Forge asks these permissions which are not needed anymore and “Allow access” fails.
These scopes are not anyhow in our app anymore. Even developer console does not show these scopes. We have been uninstalling everything multiple times. Tried in every platform and same. From some place Forge still thinks we miss these scopes.

Please fix the mess with cross-application apps and the marketplace. If it does not work, then do not say it does!