"Request header is too large" 400 error in dashboard gadget

Hi,

From time to time we receive error reports from customers for one of our gadgets about “Bad request - 400” error with the stack trace “Request header is too large”.

The gadget sends POST requests to get the data from Server and it is the custom REST API endpoint implemented in the app.

The problem definitely exists, but I don’t understand even how to reproduce it in order to fix.

Maybe anyone faced a similar issue in the past? I’d appreciate any suggestions on how to investigate such a problem.

Vasiliy

Vasiliy, in the end did you resolve the issue?

I have the exact same issue right now. Until a couple of days ago I was using the dashboard without issue, now for the last couple of days and for several gadgets (not all) I get the same error message that Vasiliy had. I tried deleting them and reinstaling them, but that didn’t help.

This hampers my ability to create the reporting that my company expects me to produce.

Rene

Hi Rene,

We were not able to reproduce this issue. If it would be possible to check it out with you on your Jira, it would be helpful. I think the problem is on both sides - Jira and apps.

Hi Vasiliy,

In the end I was able to determine that the issue was caused by the browser (Chome). If I used a different browser I would not get the error message. I removed Chrome and reinstalled it and then the issue was solved.
No idea what exactly went wrong, but I know what the issue is now and how I can fix it if it happens again.

Rene.

Hi Rene,

Thank you!

Hi Vasiliy,
we have the same issue and a browser change does not help. Have you found a solution?