REST API errors with 404:No message available

I am using Oauth2 for authenticating the Confluence Cloud APIs. All user, groups and search content APIs are failing with 404 error.
I have also not used offline_access scope to get the token here and have set the app refresh token setting to rotating.
I am able to hit the accessible-resources API successfully with the generated token. But none of the other APIs work.

Scopes added to the app and response of the accessible resources API :

Groups API response with error :


It all works for me. I tried:

All return results as expected. If I modify scopes, I can force Confluence to 401, but you have the right scopes. And, you get a 404, which makes me suspect the cloudId. Except, I can plainly see the match between accessible-resources and /ex/confluence/.

I’m curious if you can call the parallel API using only an API token?

Thanks for validating @ibuchanan.

After all the debugging I found the site was down for some reason, hence none of the APIs worked.

Restored it and the API works now.

1 Like