REST API search giving 400 Bad request

Any request I do to /search/ gives the error 400 Bad request.

I’ve tried:

  • rest/api/2/search?jql=project=CLONESUP
  • rest/api/2/search?jql=project%20=%20clonesup
  • rest/api/2/search

And a lot of variations urlencoded and not urlencoded. All give “Bad request”.

That’s kinda odd, how are you trying to make this requests?

Javascipt. All other requests work, but search does not.

ill try to check tomorrow, but one thing u might try is to add, mb it will help idk) / before any of those rest/api/2/search?jql=project=CLONESUP so that /rest/api/2/search?jql=project=CLONESUP just in case :smiley:
but now i think that doesn’t matter, since u get 400 error code, anyway, ill try to see myself if i can do the same

I only copy/pasted the relevant part. Full call is :slight_smile:

Solved it by using POST instead of GET. The GET should have worked too if I understand the documentation correctly.

the GET will work but you’ll have to url encode the = in the value part of the query string.