RTE Javascript Error

One of my customers is getting the following error. Does anyone know what it would relate to:

batch.js?agile_global_admin_condition=true&is-server-instance=true&jag=true&jaguser=true&jira.creat…:5082 RTE not registered  Error: No jira/editor/registry
    at callDep (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:6)
    at req (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:6)
    at window.require (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:9)
    at initialiseBehaviours (batch.js?agile_global_admin_condition=true&is-server-instance=true&jag=true&jaguser=true&jira.creat…:5082)
    at HTMLDocument.<anonymous> (batch.js?agile_global_admin_condition=true&is-server-instance=true&jag=true&jaguser=true&jira.creat…:5082)
    at j (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:38)
    at Object.fireWith (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:39)
    at Function.ready (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:27)
    at HTMLDocument.Q (batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:37)
    at <anonymous>:2:297

My plugin is behaving weirdly (code that normally works correctly suddenly isnt) and this is the only error in the javscript console



Just would like to raise my hand up, some customers get same error when using my plugin, that does not seem to relate to the problem - maximized gadgets are empty.

Any help?

I also get this error in my add-on on non-issue pages but it only cause minor problem. I think this error is related with rich text editing. When this error occurs work log comment field doesn’t show new rich editor.

@paul, could you provide us with some more details (Versions, plugins installed,…)
And a possible way to reproduce this problem so we can check it out?

@azhdanov and @denizoguz feel free to add your information here too.

1 Like

Stack trace looks a bit different in my case, and it occurs every time any gadget (dashboard item) is maximised on JIRA Dashboard (7.0.3, 7.1.7 or 7.3.1):

batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:174 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
send @ batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:174
ajax @ batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:169
setView @ batch.js?agile_global_admin_condition=true&hc-enabled=true&is-server-instance=true&is-system-admin=…:926
publicInterface.setView @ batch.js?agile_global_admin_condition=true&hc-enabled=true&is-server-instance=true&is-system-admin=…:926
(anonymous) @ batch.js?agile_global_admin_condition=true&hc-enabled=true&is-server-instance=true&is-system-admin=…:926
dispatch @ batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:82
h @ batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:74

However real concern is that Timesheet gadget has no content when maximised, but there is no any other error anywhere else. It happens for two customers at least on JIRA 6.4.10/7.1.6 and 7.1.7, but I can’t reproduce it.

Hi @pvandevoorde, the customer is using JIRA project management software - 7.1.9#71013-sha1:1aa0586.

The List of plugins (taken from a screenshot) is:

  • Comment Security Default (My plugin)
  • Adaptavist ScriptRunner for JIRA
  • Asana Importers Plugin for JIM
  • Atlassian JIRA - Plugins Instance Health Plugin
  • Atlassian Universal Plugin Manager Plugin
  • Atlassian Universal Plugin Manager Self-Update plugin
  • Device42 JIRA Connector
  • Entity property conditions
  • Filter Deletion Warning Plugin
  • Go2Group CRM Plugin for JIRA
  • JavaMelody Monitoring Plugin
  • JIRA Feature Keys
  • JIRA Suite Utilities
  • JIRA Toolkit Plugin
  • JQL Tricks Plugin
  • katl-commons
  • Kepler Custom Fields
  • QaSpace - Test Management
  • Quick Subtasks for JIRA
  • Show Saved Filter for Columns for Jira
  • Soy Funciton Plugin
  • Structure
  • Support Healthcheck Plugin
  • Support Tools Plugin
  • Warden

Looks like the Rich Text Editor is not one of the installed plugins

In my case the stack trace is like this:

RTE not registered  Error: No jira/editor/registry
    at callDep (almond.js:171)
    at req (almond.js:336)
    at window.require (almond-noconflict-post.js:21)
    at initialiseBehaviours (clientvaljq.js:1777)
    at HTMLDocument.<anonymous> (clientvaljq.js:1964)
    at fire (jquery.js:1075)
    at Object.fireWith (jquery.js:1193)
    at Function.ready (jquery.js:435)
    at HTMLDocument.DOMContentLoaded (jquery.js:949)

@pvandevoorde, have you been able to reproduce the problem?

@paul not yet sorry. I’m currently at Summit and AtlasCamp in Barcelona so I won’t be able to get back to this very soon.

Hey, @paul, could you solve that? I’m getting a similar error message on my browser console while trying to implement the jira-editor-ref-plugin

1 Like

@freis, the customer is still having the issue as far as I know

I was testing this tutorial and i got the same error as you, did you manage to fix it?