Running Jira via atlas-run keeps freezing Google Chrome because it is trying to load ~2300 of JS and CSS files

I have a problem when I am running Jira via the atlas-run command. When I try to browse it, via http://localhost:2990/jira/secure/Dashboard.jspa (or any other page) it keeps freezing my Google Chrome because it is requesting too many CSS and JS files, around 1300 requests up to 2300 requests per page (the number depends on what page I am on).

I am not running any custom plugins, I am using the following minimal example:

<?xml version="1.0" encoding="UTF-8"?>

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <groupId>com.example</groupId>
    <artifactId>plugin</artifactId>
    <version>1.0.0</version>
    <name>Example</name>
    <packaging>atlassian-plugin</packaging>

    <build>
        <plugins>
            <plugin>
                <groupId>com.atlassian.maven.plugins</groupId>
                <artifactId>jira-maven-plugin</artifactId>
                <version>${amps.version}</version>
                <extensions>true</extensions>
                <configuration>
                    <productVersion>${jira.version}</productVersion>
                    <productDataVersion>${jira.version}</productDataVersion>
                    <applications>
                        <application>
                            <applicationKey>jira-software</applicationKey>
                            <version>${jira.version}</version>
                        </application>
                    </applications>
                    <compressResources>false</compressResources>
                    <enableQuickReload>true</enableQuickReload>
                    <enableFastdev>false</enableFastdev>
                </configuration>
            </plugin>
        </plugins>
    </build>
    <properties>
        <amps.version>8.0.2</amps.version>
        <jira.version>8.5.3</jira.version>
    </properties>
</project>

To reproduce the problem, simply create pom.xml with the contents above in an empty directory and run atlas-run command.

After bit of investigating, I have found that each page has around 2300 <link> html tags in the <head></head> section, on every page.

I can’t list all of the items and post it here, because trying to view that html content freezes both my Google Chrome and FireFox. I can’t even save a HAR file, because the action never completes.

This does not happen if I run Jira by downloading it and installing it manually, or when running through Docker docker run -p 8080:8080 -it atlassian/jira-software. In that case, the total amount of requests is around 200, which does not freeze my web browsers.

Why is Jira loading ~2300 of JS and CSS files when running via atlas-run ? I am not even running it in a debug mode.

I have tried the following:

  • Changing Jira version in pom.xml
  • Changing AMPS version in pom.xml
  • Changing web browsers (haven’t tried Safari)
  • Switched from Linux to Windows, same thing
  • Trying to browse Jira in incognito mode
  • Removing all plugins/addons from the web browser(s).
  • And couple of more things…

Yes, I don’t have to use atlas-run, there are other options, but I need atlas-run for quick reload for my plugin development.

What can I do so that Jira doesn’t freeze my web browser? Why does it need ~2300 files?

2 Likes

You can press the key “b” while on your Jira dashboard/most jira pages to switch to batch mode. But this will make development/debugging hard. If you can’t access dashboard probably enabling <compressResources>false</compressResources> will switch to batch mode.
Older chrome versions had this problem, however I don’t have it in recent Chrome versions.

Also since you have jira-maven-plugin I recommend mvn jira:debug -DskipTests instead of atlast-run

2 Likes

I apologise for a late reply. The <compressResources>false</compressResources> did solve my problem. Thank you very much! You have saved my life.

1 Like