SDK baseURL doesn't map beyond localhost

I’ve just installed the SDK, and built the Confluence app. When I run atlas-run, it creates Confluence okay, but it only responds to localhost:1990/confluence. Even though each page alerts me to the baseUrl being different in the config, the browser times out when I try and access it via the proper baseUrl.

I’ve tried adding the baseUrl to the local hosts file, as well as adding an alias to the tomcat server.xml, but no joy.

I haven’t done anything with the SDK other than try to get it running. Everything seems to work, it’s just this annoying disconnect with the url.

Running on a MacPro with plenty of everything.

Thanks in advance.

Hi Anthony!
Try adding this parameter to your arlas-run command:
atlas-run ... --server localhost
It should not complain again :slight_smile:


1 Like

Thanks, Angel.

It turns out that didn’t work. What did work was changing the config page to localhost. Of course, minor nit, this means nobody can brows to my dev instance. I’m hoping that’s the only side effect.


It’s the only side effect. Out of curiosity - do you have a firewall on your machine? It could be blocking external connections.

Thanks! I’m looking into that with local IT.