Set featured: true for Cloud App not working

Hi all,
we have developed an app for Confluence Cloud with the atlassian-connect-express framework.
According to the documentation, we have set "featured":true in the dynamicContentMacros section of the app descriptor. But still the app is not shown under the dropdown menu to “insert more content”, only when going via “View more…”
Did we miss something?

Thanks for any hint!

1 Like

Could you please share the dynamicContentMacros module part of your descriptor?

Sure!

  "modules": {
    "dynamicContentMacros": [
      {
        "width": "100%",
        "height": "310px",
        "renderModes": {
          "default": {
            "url": "/viewer-static"
          },
          "pdf": {
            "url": "/viewer-pdf?pageId={content.id}&diagramName={diagramName}"
          },
          "word": {
            "url": "/viewer-pdf?pageId={content.id}&diagramName={diagramName}"
          }
        },
        "url": "/viewer?pageId={content.id}&macroId={macro.id}&diagramName={diagramName}&pageVersion={content.version}&outputType={output.type}",
        "description": {
          "value": "Modeling Tool",
          "i18n": ""
        },
        "icon": {
          "width": 80,
          "height": 80,
          "url": "/assets/css/images/logo.png"
        },
        "documentation": {
          "url": ""
        },
        "outputType": "block",
        "bodyType": "none",
        "featured": true,
        "parameters": [
          {
            "identifier": "diagramName",
            "name": {
              "value": "diagram name",
              "i18n": ""
            },
            "description": {
              "value": "Name of diagram to visualize",
              "i18n": ""
            },
            "type": "string",
            "required": true,
            "hidden": false
          }
        ],
        "name": {
          "value": "Diagram",
          "i18n": "featured.label"
        },
        "editor": {
          "url": "/macro-dialog",
          "width": "100%",
          "height": "100%"
        },
        "key": "macro-enterprise"
      }
    ],
    "dialogs": [
      {
        "url": "/edit-diagram.action?pageId={ac.pageId}&macroId={ac.macroId}&appMode={ac.appMode}&fromMode={ac.fromMode}",
        "options": {
          "width": "100%",
          "height": "100%",
          "chrome": false
        },
        "key": "editor"
      }
    ]
  }

@aagrawal2 do you have any hint for us what we are missing?

Apologies for the delay. I missed your reply. Let me discuss this with our team and I will get back to you ASAP.

Do you have any news? :slight_smile: