Somethin's gone wrong message

I deployed a simple application on the cloud. It is using spring boot and velocity. The test case just returns Hello World in html format.
I can see that the application is called via GET, and it returns correctly with code 200.
However Atlassian instead of rendering the returned result spends quite some time displaying a timer then pops up a message Something’s gone wrong.
I debugged using the browser and I can see there how the call is made and code 200 is returned.

I am using authentication none, so I do not think this is an authentication problem.

Sounds like this:

Please try different browser and let Atlassian know in the ACJS-1156 about your problem.

There is dedicated thread also: Apps fail to load due to timeouts


Thanks jack. I tried: chrome, Firefox, brave. Same result.
The thread you are referring me to is mentioning that “sometimes” this happens but in my case it happens constantly all the time.
Also the thread is talking about javascript possibly not being loaded into the browser in a certain amount of time. In my case the return is just plain html.
I have already sent a message to Atlassian support but they seem to think that I need to get an answer from the community because my account is just free.
However, what seem to happen is that their product is not functioning correctly and they should address such a problem that can affect anyone using it.

The message you’re getting is more than likely because of the all.js not being loaded. If it is in your document then check the links that @jack mentioned.

Hi @PetruSimionSimitechL,

Also the thread is talking about javascript possibly not being loaded

That was an incorrect suspicion AFAIK. From our experience all.js loaded correctly (http 200) but was not picked/executed for some reason (this is the part that Atlassian will investigate hopefully).

Please open your browser console and look for a “timeout” message as presented on some of the screenshots in the other thread.
Also, you might try to install some other apps and check if they work fine. AFAIK, the problem, if present, affected all apps (so the other app will fail too).

@jack What I recently noticed is that the same behaviour is encountered when I am using the ecosystem. There is a Training link under the Add on, that results in the same behaviour and error message. This seems to be not related to the plugin I am testing. I have checked a few other things such as the Internet Level - Medium, cookies allowed etc.

@danielwester I am not using javascript at all. Just returning html straight from a controller. I am using spring-boot.

Yes but Atlassian Connect requires a javascript to be established between the host (Jira) and your app in order for the host to determine if the html document has been loaded so it can be shown.

Take a look at the network tab in the browser’s developer tools and make sure that the all.js is being loaded.

If that file isn’t loaded on the client side - then your content won’t be shown.

From my experience, when then problem happens, it affects all the apps available on the page.

image https:/uploads/default/original/3X/7/9/794bc9c6352bf0ea7f6b565112df533d1abd65a2.jpeg

@jack I figured out how to go around it. Found it on this thread:

It is adding script with src

to my html.

That solves the problem. Sorry, I didn’t think about so trivial solution :confused:

However, if Atlassian thinks we need to add javascript sources to any code that is being passed from an add on app to the cloud instance, they should have a clear documentation of that and also documentation of how to fix errors that are thrown by the atlassian instance. In essence an add on needs to supply javascript that is being used by the cloud instance in case the code in the cloud instance results in a timeout. Very questionable in my oppinion.