Apps fail to load due to timeouts

Hello,

for about week or two we’ve been getting reports from our customers that occasionally our apps fail to load and the standard message is shown instead (the one with large yellow triangle, that advice to contact app’s developers). We think that this is a problem that may be affecting other vendors as well (please see the screenshot). The requests for iframes’ content are successful but nonetheless Jira says that it couldn’t load the add-ons. We are not sure if this happens on pages other than issue view.

Best regards,
Maciej Opala

3 Likes

Hi @maciek,

The timeout error is displayed if the host product (Jira in this case), fails to set up the JavaScript API with the app. This often happens when all.js is not loaded by the app into its iframe. If this is occurring intermittently for a number of different apps and users, then there might be a reliability issue we need to investigate.

I’ll draw the engineering team’s attention to this.

Regards,
Dugald

3 Likes

So maybe it’s a problem with availability of all.js? What worries us is that all add-ons time out and there is not a single day without a new report from our customers. We even got a story that an employee was severely reprimanded by their boss due to not completing checklist items. It’s crucial for us and other vendors that the apps can be reliably accessed.

This is being investigated under https://ecosystem.atlassian.net/browse/ACJS-1134, although nothing conclusive has come to light yet.

And now it is happening on our STG Jira for all the plugins we tried:

There are also more and more customers reporting the problem.

More facts:

  • it affects issue list view /projects/DC/issues/ (full single issue view works fine)
  • it affects only Chrome in my case (Safari and FF work fine)
  • disabling all extensions in Chrome doesn’t help
  • disabling cache in Chrome doesn’t help
  • restarting Chrome (with all extensions disabled) solved the problem
  • enabling all extensions didn’t make the problem reappear
  • restarting the Chrome (with all extensions enabled) didn’t make the problem reappear

Update: it looks like there was coincidence and the steps listed above do not solve the problem. Also, the bug affects other browsers too.

We’ve just got a report about a similar problem on configuration pages. In this case, it fails in all browsers that I’ve tried (Chrome, Safari, FF).

And I was experiencing the same problem on our Jira for all the installed plugins, just a few minutes earlier.

Something wrong is happening:

Hi @jack,

Can you give an indication of how reproducible the timeouts are that you’re reporting. The issue being investigated under ACJS-1134 is extremely rare so I want to be clear we are talking about the same problem.

Regards,
Dugald

Hi @dmorrow,

They are very rare. I experienced the problem myself today and it was happening for all the page loads during a few minutes period. After that, the problem disappeared.

However, with over 10k customers, we get a few support request a day with the report suggesting this exact problem.

It started happening around 2-3 weeks ago. Before that, we were getting around 1-2 reports per fortnight and they were related to firewall/proxy blocking requests to our servers.

So, from our perspective the problem is very visible and troublesome.

Cheers,
Jack

Thanks @jack, that’s useful information. The team are actively looking into this.

Hey @dmorrow

Our customer is also facing similar issue. QMetry App not loading bcoz of timeout.


Thanks,
Umang

1 Like

Hey, same here!

Our customers have been reaching out with this issue as mentioned by @jack

@dmorrow can we point our customers to the mentioned issue?

Same here (JMWE for Jira Cloud)

Hi @david2, @vit and @umang.savaliya,

Do you have any metrics indicating how often this occurs? Our indication is that this is extremely rare, but if believe otherwise then please let us know.

Regards,
Dugald

Only one such report so far, but what’s interesting is that Atlassian support couldn’t reproduce when connecting you the same platform. Looks like the error “sticks” to the browser even after a refresh. But investigation is still underway.

In our case three report from customer… once this issue start it will continue till 30-45 min. after that its start working… Some time our internal development team also face the same issue with same duration.

1 Like

@dmorrow we had 3 cases reported by different customers for different Apps, reported on the dates:

  • 28.07.2020
  • 31.07.2020
  • 06.08.2020

I would like to note that “extremely rare” is a subjective definition :slight_smile:

Unfortunately, we are only aware of the cases that are reported by the customers (which could be just a vocal minority). The problem is that this error doesn’t seem to be logged anywhere (and technically, if our Apps don’t receive a request which seems to be the case — we can’t log it, so there is no way to tell the frequency of the error occurrence).

I don’t mind the fact that there may be issues, but I find it very frustrating that customers are being told to contact the developer for support.

image%20(9)

clockify

3 Likes

Hi,

I’ve been seeing this issue too in the last couple of weeks with our app ScriptRunner for Jira Cloud. It consistently appears around the start of day when my browser re-opens with yesterday’s tabs but it also re-appears after a few hours of use. Clearing my cache and closing the browser fixes it but this issue always comes back. I suspected it might be related to caching, seeing others with the same issue is somewhat comforting as hopefully Atlassian will look into a solution as this is indeed very frustrating.

Thanks,

Ryan

3 Likes

We are also observing this in one of our instances. The interesting thing is, that is does only appear in the issue popup:

If we open the issue in a new window, it loads without problems.

1 Like

Atlassian staff, I know the root cause might not be easy to find, but please fix it - we are already getting negative reviews for what customers think is our failure and I’m sure other vendors are also getting such reviews.

4 Likes

We’re seeing something similar quite often. Here’s an incident thread we created before being aware of this other thread: https://community.developer.atlassian.com/t/apps-including-automation-for-jira-do-not-load-and-show-an-error-message/40639/8

Last customer reporting this was today August 19 2020 at 10:40 BST. And the customer came back 10 minutes later saying that after clearing cache the app started working again. This is not OK tbh, customers having to clear caches to make apps work, most will just drop the tool thinking is broken given that native pages work. And they’ll wind up giving bad reviews like @maciek pointed out.

As mentioned in the thread I linked to, we had one of our devices experience this and it wasn’t only our apps but any apps on that device failed to load, including Automation for Jira, whilst native pages worked fine. So might be related to connect service…

I also raised a ecosystem ticket on 20th July about this which was just answered today: https://ecosystem.atlassian.net/servicedesk/customer/portal/9/AMKTHELP-24791

1 Like