Apps fail to load due to timeouts

Hey @dmorrow, Again two cloud instance was impacted causing “Something’s gone wrong”. it’s start work after 10-20 min.

we also raised support ticket yesterday.

1 Like

Hi @dmorrow,

Our customers are still reporting the problem. However, it is not as frequent as it was 3-5 weeks ago. Now we get around 1 report every second day.

So, if Jira team was adding some improvements, that worked. But the problem is still there so we would be grateful for some more work on it.


Hi @jack,

Thanks for the update. I don’t think there have been any intentional improvements, but the team is still investigating this under ACJS-1134.


Hi @dmorrow,

I am wondering if we have 2 different cases here, I will explain ours. Our customer can’t open the app. Clicking on the link shows the loader for a minute and then shows an error message:

The problem seems to come and go. During the time the link was not working, on the app’s server side we didn’t get any GET messages - even the GET to render the page. Therefore I believe it is not a problem with all.js itself, but something with Jira not sending the request for the page (as mentioned earlier it may be a different case that some vendors have).

What we also noticed: strange redirect. When you click on link it starts with
After a few seconds the URL changes to

Two things to notice:

  1. after a few seconds “:” is replaced with %3.
  2. Url of instance - is (I guess) in older format, however we have experienced the same problem on our new instances as well

Further findings:

  1. Sometimes clearing cache helps, sometimes not.
  2. At the same time, the page under project is not working, other pages, e.g. admin pages of the app are working.
  3. We got first report about this on August 14, 2020, 7:55 PM

Hi @maciej.dudziak,

Thanks for these details. I created a few weeks ago for odd change in the URL. I’ll see if I can get some action on this.


1 Like

Hi @dmorrow,

One of our user also log this strange behaviour after click on any link on app. URL got changed. Also make note it’s just intermittent and not every time reproducible.

Working URL:

Faulty URL:


1 Like

@umang.savaliya, thanks for also adding a comment to the issue.

1 Like

Just adding that some of our customers are seeing this issue as well.

1 Like


Over the last month we’ve run an extended investigation and made several improvements, but don’t believe we’ve found all the causes of the recent increased number of apps failing to load since August.

In particular, we haven’t found any evidence that our CDN that serves all.js is to blame.

We’re in the process of building out additional analytics to help us isolate the cause and hope to have data from those soon

The issue is affecting our customers and us vendors since early August. Customers blame us, what we can see not only in the AMKT reviews (see this comment) but mostly in the support cases we have to deal with.

If the message on the screenshot below comes from Jira, it should be pretty easy to start the investigation from the exact place that prints it.

Yet, almost three months passed, and Atlassian admits to spending only 1 month on the issue, closes the main part of the investigation with no results at all to the main problem.

I can’t express how disappointed I’m am. And I can’t imagine ourselves doing the same to our customers.

Let me quote one of the other vendors (I hope they don’t mind). It is a perfect summary of the vendors-Atlassian relationship.

i think each Atlassian team should have to spend 1 week in “vendor jail”… where they are tasked with doing the things we do, only given the resources we get, and they are not allowed to ask for internal help. CDAC and non-responsive support tickets only


@dmorrow, @dboyd, any progress regarding the timeouts problem, please?

Sadly, the issue is not gone. We still get support cases with customers reporting the very same issue - apps simply fail to load and time out.

Hi @jack and @maciek,

I can confirm that the development team are still actively working on this issue. I will ask the team to pro-actively share progress.



I have one user in one customer with one user reporting the same problem. It seems to be browser specific
“the actionableagile tab in any project triggers an error stating an error has occurred and to contact atlassian support. This is only occurring for one user and all other users are able to utilize the plugin just fine.”

"Hi Julia,

The user with the issue has attempted two different browsers and a cleared cache, to no avail. I’ve reached out to Atlassian as well.

Thank you"

"Hey Julia,

if you could help us escalate the situation that would be great. We did troubleshoot further and found that actionableagile works within Safari, but not Chrome. There are also no events within Chrome’s console that are out of the ordinary.

Thank you."

hi @JuliaWester - unfortunately I don’t have access to: - Could you please tell me which browser the customer is having issues with? I can relay the info to the team investigating this. Thanks!

I have raised a new issue to track this investigation

My current suspicion is that this is an issue with iframes and caching - which have historically been problematic. I’m trying to reproduce the issue so I can work on a fix for this, so far I have not been able to.



1 Like

@mstaas, I don’t have permissions to access

Can we make it a public issue?


@jack sorry I didn’t realise the default permission on that project was private, the issue should be public now.


Just adding my voice that we’re starting to see more and more customers reporting this.


Same for us.