Standalone Bitbucket Server 404 Respomse

I’m just a beginner in Atlassian Plugin development. I tried to run the standalone version of Bitbucket server using atlas-run-standalone --product bitbucket from the console/terminal it looks every thing is fine and the server started without errors, I got the following message in the terminal.

[INFO] [talledLocalContainer] Tomcat 8.x started on port [7990]
[INFO] bitbucket started successfully in 1145s at http://karthik-pc:7990/bitbucket
[INFO] Type Ctrl-D to shutdown gracefully
[INFO] Type Ctrl-C to exit

But when I tried to access the application in the browser using the URL in the log I’m getting 404 error as below.

How to access the Bitbucket server?

Until the Atlassian SDK gets updated, it needs some help running with Bitbucket Server 5.0+. Try this:

atlas-run-standalone --product bitbucket -u 6.3.1

If that doesn’t work, it’d help to see a bit more of what’s being output after you type the command.

1 Like

Above command resolved the issue thanks.

Hi - I am having the same problem. Using 6.3.1 does work – thanks for that.

How are we supposed to test on 5.2.3 or 5.3.1? Is the SDK going to get updated?


Just to be clear, the -u parameter specifies the version of a library used by the Atlassian SDK. The --version parameter specifies the version of Bitbucket Server.

atlas-run-standalone should automatically find the latest version of Bitbucket Server and run that (currently 5.4.0). If you want to run an older version (or if it’s failing to find the newest version), use the --version parameter.

For example, you can run Bitbucket Server 5.2.3 with atlas-run-standalone --product bitbucket -u 6.3.1 --version 5.2.3

1 Like

Thanks for your reply! I will try this out and follow up.