Suddenly Unable to run app : "The app is not installed on this instance."

Hey I am running my app in VS code to fetch data from Jira. The app was working fine last week when i ran the app. But today when tried to run the app using “python”, it gave me this error: “RuntimeError: Received invalid response from JIRA API: {“errorMessages”:[“The app is not installed on this instance.”]}”.

When I try to run the app again, it is showing the error: “RuntimeError: Received invalid response from JIRA API: {“errorMessages”:[“Access to the resource was denied due to missing scope grants. Your app was granted the following scopes: .\nThe resource can be accessed by having one of these groups of scopes:\n * [read:jira-work]\n * [read:issue-details:jira, read:audit-log:jira, read:avatar:jira, read:field-configuration:jira, read:issue-meta:jira]\n”]}”

However I have all these scopes added in the app.

Everything was working fine last week, but today I am getting all these errors.
Can you please help me out?

Hey @NitaiBhasin

Welcome! First off, make sure your OAuth 2.0 credentials are still on point and that your app is still installed in Jira. Check if the scopes are still a match. Also, see if anything in your code changed recently. If all else fails, test your API requests outside the app with tools like Postman to see if it’s a broader issue. If you’re still stuck, share some more details about your setup. We’re here to help!


@NitaiBhasin Were you ever able to find a fix or workaround for this?