"The app could not be installed as a local app as it has previously been installed from Atlassian Marketplace" for marketplace install

I’m trying to update one of our app staging environments on my personal Confluence instance. The app is a private app in marketplace that we install using the private listing tokens.

This instance has never had a local app installed always private marketplace apps. Now it seems like I can’t update the app anymore getting the infamous The app could not be installed as a local app as it has previously been installed from Atlassian Marketplace.

Is this an error in the UPM or a change? My reading of Change notice - Changes to installation of a local app on Atlassian Cloud products is that only installs from non marketplace sources will be prevented, not private marketplace token installs.

3 Likes

We get the exact same error message, @shannon could you find a solution for this problem?

According to what I’ve been reading about this problem, this is a change in UPM to avoid Jira administrator to get confused between marketplace listed apps and development apps.

Another article here

Point is, that if a previous installation has been made with an app in private mode (and an app which has never been publicly listed), then there is no confusion possible.

I would then suggest that this limitation does not happen if the app was never listed publicly in the marketplace.

My 2 cents.

This just hit me today, because I think I switched authentication to JWT, to address another API issue. Now I can’t test in staging before pushing a change to production (it’s been working fine until now).

Ok. So I worked out that I had to distinguish my different development, staging, and production versions in the key using a dash not a dot. E.g. com.my-unique-app-key.staging.this-app didn’t work, but com.my-unique-app-key.staging-this-app did.

1 Like