Timeout error when creating webhook with API endpoint `rest/webhooks/1.0/webhook/`

Hi all!

For the past few weeks I’ve been building an integration between monday.com and Jira. One of the necessities for this integration has been to add a Jira webhook upon subscription using basic authentication.

This has worked fine up until earlier this week when all of my requests to rest/webhooks/1.0/webhook/ have timed out without any other helpful error message.

I also tested it out with other endpoints and they’re all getting timeout messages. Could there be an issue with my account?

Thanks in advance!


Could you clarify, when you say “getting timeout messages”, those are emitted by your HTTP client?

I just ran a request on my Jira Cloud site using Insomnia and I got a response in under 150ms. So there’s not a global problem.

It could be a problem with your account, but I would have expected a 429 response if you were hitting rate limits. Maybe to rule out a problem between your client and Jira, you could make a request using a hosted HTTP client?

Hi @ibuchanan!

Yes I’m assuming it’s emitted by my HTTP client? Not 100% sure?

I’m also testing with Postman and I get the same error:

This is my account: https://mondaytestaccount.atlasssian.net/


I can’t see any reason your site would be having a problem. Maybe you would be better off using the new OAuth 2.0 for the newer webhook endpoint as announced just recently:

Hi @ibuchanan!

Thanks for getting back to me-- we would prefer using basic authentication as it’s just an example app that we’re building.

Is there any reason that you could think of as to why these requests are timing out now? I’m assuming the previous endpoint (the one I posted above) is working for you though, right?

Is there any way for us to submit a bug report on this issue? I’m under a bit of a time crunch to push out this example integration.

I also wanted to add that all requests from my account don’t seem to be going through and are all resulting in a time-out (i.e. fetching an issue’s fields via a GET request).

Thank you!


I confirm all APIs, including 1.0 webhooks one work for me. And there don’t seem to be any known incidents on our APIs. I think our customer support path would be the best option.

Thank you @ibuchanan!

Always so helpful

Hi! For all future readers,

The issue was that I had included an extra “s” in my URL (i.e. “atlasssian.net” instead of “atlassian.net”).

Ohhh the joys of coding !

Seplling mistakes are the wurst! :hotdog: