Trying ACE with Hello world tutorial, to no avail

I’ve been following the tutorials in here and here, which should be the same.

Set up my Jira Cloud development instance, activated the Settings flag to upload apps. I also added the credentials.json, as ordered, with the info of my URL dev site, my e-mail (which is and org& site admin account) and the API Token, generated as explained in the tutorial.

npm start, F5 on the dev site, and no trace of the “Hello world” tutorial app.

I’m feeling a bit dump, since that’s just the beginning of a well documented tutorial, still no way to run the app.

1 Like

Hi @franquintero,
If you click on the Apps drop down in the UI, do you see the “Hello World” menu item?

Here is how it should look like:

After clicking on it, does this page display?

If this isn’t there, the next things that I would check are:

  • Does the app appear to be installed when browsing to the “Manage your apps” page available at https://<your-site>.atlassian.net/plugins/servlet/upm?
  • The logs in the console when running npm start. Is there any log there? Maybe an indication of errors? Is there a line saying Registered with host at https://<your-site>.atlassian.net/?

If you are just getting started with app development, or if you want to try the latest framework, head over to the Forge pages: https://developer.atlassian.com/platform/forge. You’ll find an “Hello World” tutorial there as well: https://developer.atlassian.com/platform/forge/build-a-hello-world-app-in-jira

Cheers,
Caterina

2 Likes

Hello @ccurti !

The apps on the drop down menu doesn’t show anything, moreover I don’t see the app installed.

After npm start console shows this:

I tried the Hello World app without ACE and it went smooth, but I want tro try with it since it automates things like app integration (although it seems something is failing there) or app re-registering.

1 Like

@franquintero for comparison, here is the output that I get from the console:


> my-app@0.0.1 start /Users/ccurti/Documents/devexp/ace_test_app
> node -r esm app.js

morgan deprecated default format: use combined format node_modules/esm/esm.js:1:278827
Watching atlassian-connect.json for changes
App server running at http://ccurti:3000
Local tunnel established at https://77e06c3d6944.ngrok.io/
Check http://127.0.0.1:4040 for tunnel status
Registering add-on...
GET /atlassian-connect.json 200 12.557 ms - -

It looks like the first difference is the Local tunnel established at https://77e06c3d6944.ngrok.io/ line.

Are you sure that ngrok is installed? You could try to run ngrok -v to double-check.
It should log an error if it’s not installed, but maybe some unusual condition is happening on Windows. If it helps, here is the source code for the ngrok check.

I also found interesting that there was a Re-registering message, was the atlassian-connect.json updated or is that message logged every time when using npm start? Here is the source code for that.

1 Like

Hi again!
ngrok -v gives the following line:
ngrok version 2.3.40

Yup, that re-registering was due to a change I did to atlassian-connect.json (basically I added key, name and description for the app)

On atlassian-connect.json, baseURL is still {{localBaseUrl}}, which I think is referenced in the config.json file, which right now is:
“localBaseUrl”: “https://my-subdomain.herokuapp.com

1 Like

Hi @franquintero did you found solution for this issue ?
I’m having the same issue

@Pcmina I know it’s been some time just faced something similar with the Local tunnel established message not being reported and I realized that I didn’t have a credentials.json in the root of the app.

Could it be that this is what was happening?

Also, if the tunnel doesn’t start automatically, it is always possible to create one manually by running ngrok http 3000 and installing the app manually using the resulting https URL and appending /atlassian-connect.json to it.

Caterina

1 Like