Type issues with select after upgrading to version 17

Hey there,

I updated the @atlaskit/select component from 16.5.10 to 17.10.3 (latest).

Now my IDE (IntelliJ) says, that almost all props for the select are required (check screenshot), that were not before, and I think still aren’t.

However, I can still build and use the component, but I get the warning in my IDE and wanted to double-check if somebody else has this issue as well and if there is a solution for it?

Cheers,
Marcel