Unable to build example jira project

After running ‘atlas-create-stash-plugin’ and creating the default jira plugin, I opened IntelliJ and tried to build the project. For some reason, I’m getting errors like these:

I haven’t touched the default pom.xml that is created with the above command, so I’m not sure why I’m getting these errors.
When I ran the above command for the first time, I got these errors (not sure if they are the reason I’m getting build errors):

In addition, when I look at the project structure, I see these problems:

Any help will be very appreciated! I’ve been trying to find some sort of solution to this for hours and I can’t find anything related to this problem.

Stash? JIRA? Can you clarify? Don’t create a stash plugin, create a bitbucket plugin. Stash is deprecated. Also, why do you say you run the JIRA plugin?

Finally, two notes:

  1. Be sure to set intellij to point to the Maven installation listed by typing “atlas-version” into your terminal.
  2. Be sure to set your language level to JAVA 8.

I was following this link: https://developer.atlassian.com/stash/docs/latest/how-tos/repository-hooks.html, which I got after clicking on “write your own hook” (see below)

which led me to: https://developer.atlassian.com/stash/docs/latest/how-tos/repository-hooks.html. The link under the “Generate a Stash plugin using the Atlassian SDK” section points to instructions using Stash.

Looks, Stash was renamed Bitbucket. If you find out-of-date tutorials, you need to use the equivalent command or API in Bitbucket.

Using the stash commands or API will fail.