Unable to build inhouse plug-in because of the error: Could not transfer artifact com.atlassian.jira:jira-api:pom:7.13.2 from/to atlassian-public (https://maven.atlassian.com/repository/public)

Hi,

We are going to upgrade Jira from 7.6.6 to 7.13.2. For that we are trying to build all in-house plugins to make compatible with 7.13.2. We are facing the problem to build the plug-in. Attached the text file that contains command errors.
We tried the solutions mentioned in Atlassian community but no luck. Please suggest where we went wrong or we missed anything.

Thanks,
Bharadwaj Jannu

Hello @bharadwajjannu,

Kindly add snippets of the text file contents if possible. I do not see the attached text file mentioned.

Cheers,
Ian

try with 7.13.1 or 7.13.0 all the version are not in repository

So far 7.13.1 and 7.13.2 works for me. I’m using the following versions

<jira.version>7.13.1</jira.version>
<amps.version>8.0.0</amps.version>

Hi Ian, here is the content of text file:

C:\Users\BJ255004\git\jira-businessrules-workflow-plugin>atlas-run
Executing: “C:\Applications\Atlassian\atlassian-plugin-sdk-6.3.12\apache-maven-3.2.1\bin\mvn.bat” com.atlassian.maven.plugins:maven-amps-dispatcher-plugin:“6.3.21”:run -gs C:\Applications\Atlassian\atlassian-plugin-sdk-6.3.12\apache-maven-3.2.1/conf/settings.xml
Java HotSpot™ 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
[INFO] Scanning for projects…
[WARNING]
[WARNING] Some problems were encountered while building the effective model for com.teradata.jira.plugin.teradata_business_rules:TD_Business_Rules-Workflow_Plugin:atlassian-plugin:4.2
[WARNING] ‘build.plugins.plugin.(groupId:artifactId)’ must be unique but found duplicate declaration of plugin com.atlassian.maven.plugins:maven-amps-plugin @ line 91, column 12
[WARNING] ‘build.plugins.plugin.version’ for org.apache.maven.plugins:maven-compiler-plugin is missing. @ line 84, column 21
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]
[INFO]
[INFO] Using the builder org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder with a thread count of 1
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building TD_Business Rules - Workflow Plugin 4.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] >>> maven-amps-dispatcher-plugin:6.3.21:run (default-cli) @ TD_Business_Rules-Workflow_Plugin >>>
Downloading: https://maven.atlassian.com/repository/public/com/atlassian/jira/jira-api/7.13.2/jira-api-7.13.2.pom
Downloading: https://maven.atlassian.com/repository/public/com/atlassian/jira/jira-core/7.13.2/jira-core-7.13.2.pom
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3.308 s
[INFO] Finished at: 2019-04-04T16:09:18+05:30
[INFO] Final Memory: 13M/195M
[INFO] ------------------------------------------------------------------------

continued in second reply…

[ERROR] Failed to execute goal on project TD_Business_Rules-Workflow_Plugin: Could not resolve dependencies for project com.teradata.jira.plugin.teradata_business_rules:TD_Business_Rules-Workflow_Plugin:atlassian-plugin:4.2: Failed to collect dependencies at com.atlassian.jira:jira-api:jar:7.13.2: Failed to read artifact descriptor for com.atlassian.jira:jira-api:jar:7.13.2: Could not transfer artifact com.atlassian.jira:jira-api:pom:7.13.2 from/to atlassian-public (https://maven.atlassian.com/repository/public): sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
C:\Users\BJ255004\git\jira-businessrules-workflow-plugin>

Thank you!

Based on the link provided in the error, have you checked the 6 items mentioned if it can help your situation? One of the common scenario is if you are running behind a proxy and if you are, be sure to check your settings.xml if it is properly configured (see this Maven documentation).

sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

This is a common SSL error. Are you on a corporate network? I suspect your company is cert pinning – Your local JAVA Keystore does NOT trust the certificate.

You either need to add your companies certificate chain to your JAVA Keystore or you need to work out a proxy that does not get pinned.

3 Likes

I was able to fix this issue by importing the certificate to the local java key store. I followed the guide at https://techgrafitti.wordpress.com/2011/03/02/maven-unable-to-find-valid-certification-path-to-requested-target-issue/. Thought someone might find it useful.

1 Like

We have the same problem on our corporate network, it’s quite a pain :#

1 Like

I have the same problem ,how did you fix it ? I tried importing certificate but couldn’t make it work .