Unable to create a new Confluence Webhook using 3LO

I tried to create a new 3LO apps with Confluence and already got the tokens (access, refresh) and cloudid.

I would like to create a new webhook by using the access_token that received during OAuth 2 flow. The Confluence’s webhook says that it requires “read” scope. I have added that scope in authorization URL however, the response got only other that not related to “read”. I believe that the “read” scope is for just Connects App.

I tried to check for other scopes in App Management https://developer.atlassian.com/apps/ but there is nothing related to Webhook’s scope.

Trying to call to webhook POST via “https://ssot-sandbox.atlassian.net/wiki/rest/webhooks/1.0/webhook” will always got “403: Current user not permitted to use Confluence”.

Is there any way to ask for Webhook’s grant scope in Authorization URL (3LO)?

Hey Phuwadon, welcome to the Atlassian Developer Community.

Unfortunately webhooks aren’t supported in 3LO apps at this time. To use webhooks, you’ll need to build an app via the Connect framework. There’s a feature request being tracked for webhooks in 3LO here.

As a workaround, if you need to use OAuth 2.0 authentication for your app, and you require the ability to respond to/listen for product events in the immediate term, consider trying out the Forge platform (currently in beta). Access requires an invitation at this time, but if you apply for the waitlist and let me know I can accelerate your acceptance. You can view the list of product events supported through Forge here.

1 Like