Unable to find valid certification path to requested target

Hi All,

I am working throw the tutorial create-a-confluence-hello-world-macro
I run atlas-create-confluence-plugin and get an error :slight_smile:

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 29.603 s
[INFO] Finished at: 2022-05-15T13:14:20+03:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.atlassian.maven.plugins:confluence-maven-plugin:8.1.2:create (default-cli) on project standalone-pom: Execution default-cli of goal com.atlassian.maven.plugins:confluence-maven-plugin:8.1.2:create failed: Plugin com.atlassian.maven.plugins:confluence-maven-plugin:8.1.2 or one of its dependencies could not be resolved: Failed to collect dependencies at com.atlassian.maven.plugins:confluence-maven-plugin:jar:8.1.2 → com.atlassian.maven.archetypes:confluence-plugin-archetype:jar:8.1.2 → org.twdata.maven:mojo-executor:jar:2.3.0 → org.apache.maven:maven-core:jar:3.5.4 → org.apache.maven:maven-model:jar:3.5.4 → org.apache.commons:commons-lang3:jar:3.8.1: Failed to read artifact descriptor for org.apache.commons:commons-lang3:jar:3.8.1: Could not transfer artifact org.apache.commons:commons-lang3:pom:3.8.1 from/to atlassian-public (https://maven.atlassian.com/repository/public): sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target → [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] PluginResolutionException - Apache Maven - Apache Software Foundation

On my old computer, it worked properly, I have the error only on my new computer.

Thanks,
Chana

hi, sounds like an HTTPS/SSL error. Maybe you are behind a corporate Proxy/Firewall that does not allow you do download from https://maven.atlassian.com/repository/public .

Or you are on a machine where the CA-CERTS are broken for your Java Virtual machine.

here is a helpful documentation on how to find out the problem:

https://confluence.atlassian.com/kb/unable-to-connect-to-ssl-services-due-to-pkix-path-building-failed-error-779355358.html

I hope you can solve your problem :slight_smile:

Hi,
Thanks for your response!
When I realized it was related to Proxy and Firewall, I did contact the security team at our company and they took care of it thank you!