Uncaught (in promise) Error - in Forge apps using storage api


I know this issue was already addressed regarding the requestConfluence discussion.
And according to staff members the solution was released on July 27, although I’m not sure this also includes the Storage api.

I keep getting the same error:

Uncaught (in promise) Error: There was an error invoking the function - 2021-08-09T17:07:12.789Z Task timed out after 10.01 seconds

This happens only when I deploy the app to the cloud, when I tunnel the app the error disappear.

I have already upgraded the bridge directory with npm install @forge/bridge@latest

Is there any way around this issue?
Please help!

Just to confirm this error occurs for non-production environments, right? Trying to eliminate the possibility that you have different amounts of data in the different environments that could be causing this issue.

1 Like

Hi @bentley!

This happens if I deploy the app to either development or production, both stages seems to have this issue.
When I tunnel the app and serve it locally, the error goes away.

Hi @bentley !

Is there any chance this would be fixed before you’re hackathon’s deadline?
I’ve built an entire Forge app, everything works perfectly, except for this issue.

Starting to lose hope :pensive:

Can you provide anymore context? It sounds like it is something specific to how you are using storage.

Can you post a sample app that has the minimum viable code to reproduce it?

Alternatively, have you tried messing with your own apps a bit to use storage in a different/simpler way? Trying to figure out is it happening any time you are using the storage API or just for specific calls you are making?

1 Like

Yes I have a repo just for this project, I’ll add you so you could see the code.

Hi @bentley !

Any news one this bug?
We’re on the edge of our seats here :slight_smile: