Unhelpful error when developing a Dashboard Item

I’m developing various Dashboard Items and while this issue is not a blocker for development, it’s extremely unhelpful and slows down the debugging process. Namely, while creating a dashboard item if I mess up wither the .soy template or the JS code in AMD module (e.g. I forget to pass along a @param parameter that is required by the soy template), the errors I receive are:

In the stdout of atlas-run:

[INFO] [talledLocalContainer] com.google.template.soy.tofu.SoyTofuException: In 'print' tag, expression "$dashboardTitle" evaluates to undefined.
[INFO] [talledLocalContainer] 	at JIRA.Dashboard.page.dashboard(dashboard.soy:12)
[INFO] [talledLocalContainer] 	at com.google.template.soy.tofu.internal.BaseTofu.renderMainHelper(BaseTofu.java:369)

In the browser console:

Uncaught TypeError: Cannot convert undefined or null to object
    at push (<anonymous>)
    at Array.AJS.EventQueue.push (atlassian-analytics.js:246)
Could not find AJS.whenIType, QuickReload batch mode switcher not enabled
Uncaught TypeError: AJS.log is not a function
    at RequireHandler._processResourceResponse

Am I doing something wrong or the error messages are in fact as unhelpful as they seem to me? Basically any fatal error in the .soy template or JS code of the dashboard item results in In 'print' tag, expression "$dashboardTitle" evaluates to undefined. error.


I have the same issue.
Have you solved your problem?


Got the same error, also created new thread

Did anyone solved it?