Unnecessary scrollbar in panel view

I am developing a plugin for jira cloud which have a web panel module.
Here is my obfuscated module definition:

{
        "key": "panel-key",
        "location": "atl.jira.view.issue.left.context",
        "name": {
          "value": "panel name"
        },
        "url": "/panel.html",
        "conditions": [
          {
            "condition": "addon_time_tracking_provider_enabled",
            "params": {
              "addonKey": "addon.key",
              "moduleKey": "module-key"
            }
          }
        ]
      }

Here is a screenshot of the problem:

image

An unneccessary greyed out scrollbar appears in every browser except chrome. In chrome it’s just hidden automatically instead of being greyed out, but it still takes some place.

The container of the panel has a style rule like this set by jira cloud automatically: overflow: hidden scroll;
If i replace this rule with overflow: auto; in the inspector, the panel appears as it should. But of course i can’t change this style from my plugin.

My panel is resizing automatically by the connect library, so there is no need for the scrollbar.

Is there any way i can hide the unnecessary scrollbar?

If there is no way to do this, i suggest a new module option defining the behaviour of the panel container’s scrollbar.

Please check this issue: https://jira.atlassian.com/browse/JRACLOUD-69565

1 Like

Is this really not solvable? Would be quite embarrassing to host a design guide etc. and then add an ugly and unnecessary scrollbar to every plugin. Makes the entire plugin look cheap.

Removing ac-content from the root div got rid of the scrollbar.

1 Like