User-Agent rewritten on outbound fetches

I have been trying to make fetch requests to an external source (business central) but keep receiving an error response because the User-Agent.

Sending the request to, I can see the User-Agent is set to “Forge/1.11.0 ari:cloud:ecosystem::app/”. Making the same requests from postman works, but when I change the User-Agent to copy this, it fails. It seems it does not like the “:” characters in this header.

I have tried setting the User-Agent manually in the fetch, but I am guessing since there is an explicit list of allowed external sources in the manifest the fetch is a proxy and is interupted, without forwarding on the custom User-Agent

Is this a bug? I need some form of solution as this app is useless without the ability to post but fast running out of ideas

1 Like

I have solved this by putting an azure function between jira and business central.

I don’t know how to raise this as a bug so any links that can be provided would be grateful but I do feel this is a bug on both ends of the chain.

I think its a bug in business central and microsoft should be able to handle User-Agents with a : character as it is definitely within the allowed characters in the User-Agent header, but I also think that Jira should allow us to override the User-Agent being sent to external sources.