Velocity Template ComponentAccessor in 8.20.10

Hello everyone,

We have recently upgraded to 8.20.10 from 8.2.1 and now im running into issues with custom emails which were previously working to generate a comments history

I need to start by getting the ComponentAccessor

Previously this worked: #set ($componentAccessor = $constantsManager.getClass().forName('com.atlassian.jira.component.ComponentAccessor').newInstance())

I saw this topic following a search where another user had a similar issue: Velocity NumberTool Use

From there im learning the getClass is no longer available and saw there was a solution

This was my attempt after trying to use the answer in the question above as a starting point, but its not working : #set ($componentAccessor = $constantsManager.get("jirautils").loadComponent("com.atlassian.jira.component.ComponentAccessor",$constantsManager.getClass()))

I also tried it just as written in that answer but with the ComponentAccessor class alone and it didnt work either.

Does someone know what I should call instead for that?