WebPanel show in new Jira view


How can I make sure that my WebPanel is always shown in the new issue view?
I have tried the following with no succes:

"webPanels": [
			"url": "/xxx.html",
			"location": "atl.jira.view.issue.left.context",
			"layout": {
			  "width": "100%",
			  "height": "200px"
			"tooltip": {
				"value": "Tooltip text."
			"contentPresentConditions": [
				"condition": "user_is_logged_in",
				"invert": false

It doesn’t work. I also tried to just write “true” as condition, but that didn’t work either. My Panel shows up in the quick-menu for adding it on the view, but I want it to be visible by default.


Hi @MichaelVognsenNielse,

I think the problem is with the conditions section of your descriptor. Can you:

  1. Remove the "contentPresentConditions" node and check the panel appears.
  2. Add a "conditions": [] node and within it add a very simple condition such as {"condition": "user_is_logged_in"} and check the panel still appears.
  3. Iterate on your conditions this way until you get what you want.


Hi Dugald
Thank you for your reply. I already have a conditions-node (and it’s working - see below). The problem is that it’s working only for the classical view in Jira - not the experiemental/new view that new users default to. I found the “documentation” for ContentPresentConditions" here: jiraIssueContents conditions

This is my working conditions-node, but it’s working only for the classical issue-view in Jira (not the experimental one):

"conditions": [				
				  "condition": "addon_property_contains_context",
					"params": {
						"propertyKey": "actconfiguration",
						"objectName": "visibility.issueTypes",
						"contextParameter": "issuetype.id"

Hi @MichaelVognsenNielse,

I was confused by your contentPresentConditions node in your previous post. I’ve tested the new issue view evaluates the simple condition {"condition": "user_is_logged_in"} and I guess you see the panel also in the new issue view with that same simple condition, but not when you change the condition as per your last post.

I’m a bit stumped as to why this isn’t working so I might have to create a Jira issue for this.