You cannot extract a file outside of the target path

I am trying to build the example ACE app build it is giving me this error. Any idea why?

Lastly these parameters did not help : “–unsafe-perm=true --allow-root”

C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example>npm install
npm WARN deprecated connect@2.8.8: connect 2.x series is deprecated
npm WARN deprecated mkdirp@0.3.5: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm WARN deprecated node-pre-gyp@0.11.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated sequelize@3.35.1: This version will no longer receive security fixes per our security policy. Please update to sequelize@5 or above.
npm WARN deprecated connect@2.12.0: connect 2.x series is deprecated
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated terraformer-wkt-parser@1.2.1: terraformer-wkt-parser is deprecated and no longer supported. Please use @terraformer/wkt.
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated tar.gz@1.0.7: ⚠️  WARNING ⚠️ tar.gz module has been deprecated and your application is vulnerable. Please use tar module instead: https://npmjs.com/tar
npm WARN deprecated terraformer@1.0.12: terraformer is deprecated and no longer supported. Please use @terraformer/arcgis.

> sqlite3@5.0.2 install C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download
[sqlite3] Success: "C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\sqlite3\lib\binding\napi-v3-win32-x64\node_sqlite3.node" is installed via remote

> ngrok@2.1.7 postinstall C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\ngrok
> node ./postinstall.js

ngrok - downloading binary https://bin.equinox.io/a/chRZWPptE7w/ngrok-2.1.1-windows-amd64.zip ...
ngrok - binary downloaded...
ngrok - error unpacking binary Error: You cannot extract a file outside of the target path
    at C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\decompress-zip\lib\decompress-zip.js:95:21
    at Array.map (<anonymous>)
    at C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\decompress-zip\lib\decompress-zip.js:91:25
    at _fulfilled (C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:854:54)
    at C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:883:30
    at Promise.promise.promiseDispatch (C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:816:13)
    at C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:624:44
    at runSingle (C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:137:13)
    at flush (C:\Users\Michael\Desktop\Projects\atlassian-connect-jira-dashboard-item-example\node_modules\q\q.js:125:13)
    at processTicksAndRejections (internal/process/task_queues.js:79:11)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! ngrok@2.1.7 postinstall: `node ./postinstall.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the ngrok@2.1.7 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Michael\AppData\Roaming\npm-cache\_logs\2021-04-16T12_45_37_435Z-debug.log```

Welcome to the Atlassian developer community @MertTurkoglu,

I spun up a new instance of Windows Server 2019. I was able to install NodeJS, atlas-connect, and start a new project. When I ran npm install for that project, it worked fine. I think we would need to know more about your environment, in order to help troubleshoot.

1 Like

I changed the node.js version and it worked as you said

1 Like

I’m having the same issue here, which node.js version did you use and it worked for you?