App is not responding

Hi,

I’m developing for Jira for the first time. I’m probably missing something obvious.

I’ve created a web-panel as outlined here: https://developer.atlassian.com/cloud/jira/platform/modules/web-panel/.

It took me some time to figure out how to load the template, but found routes/index.js and addd this:

app.get('/issue-tracker', addon.authenticate(), function (req, res) {
        res.render('issue-tracker', {
            title: 'Time tracking'
        });
    }
);

In the views folder I added issue-tracker.hbs and added my html.

Everything is working as expected, except the message “App is not responding” appears at the bottom of the web panel.

What am I missing here?

3 Likes

Hi Maarten,

Can you take a screenshot and post here?

We may be something similar and it appears to be new behavior.

Have you loaded all.js into your iframe?

It looks like you are using ACE but, if the all.js file is not being loaded into your iframe then the Javascript bridge will never be established between the host product and your iframe and that message will eventually show up. The symptoms would match.

Have you read through About the Javascript API?

We may have a different issue than the OP.

In our case, we’ve all of that panels that show our content but then also show the spinner with “Loading app…” and eventually “App is not responding” on an issue load.

However…

It only happens in one particular issue view context (filter view on left, issue on right). When just opening an issue, everything is fine. And if you reload the page, everything is fine. Here’s a video from one of our test instances.

all.js is being loaded everywhere.

Our Cloud app is 1.5 years old and fairly widely used. I don’t think this was happening before.

We haven’t opened a ticket yet in ACJIRA as we’re still investigating. I was searching for an ACJIRA ticket today when I came across this forum posting above that sort of sounded like what we’re seeing.

1 Like

@mark You should raise a support request.

@rmassaioli
We did some more investigation today and I want to put the results here for others to see.

Here’s some notes from my lead UI dev:

  • When an IFrame is loaded it wants to know where it’s loaded. That’s why it calls this Atlassian API: AP.getLocation.
  • Jira accidentally inserts two our IFrames but their JS connects only to one of them. That’s why it cannot detect that other IFrame is loaded and shows spinner, also it cannot respond to JS API calls like AP.getLocation.
  • This screenshot of Jira layout relates to the problem: http://take.ms/NuMvL

I’m using the NodeJS framework. Including the handlebar layout solved the issue. Inside the layout handlebar all.js is loaded. So you are probably right.

Thank you!

1 Like

@rmassaioli
We’re now fairly confident that this is a Jira bug.

We can reproduce a double iframe with this simple static example that adds a single panel.

I’ve submitted it to support.

@rmassaioli

This appears to be a known issue in Jira.

A little bit more info (and a rant :slight_smile: ) if you’re a marketplace vendor.

Honestly, I think that’s a very problematic issue that makes add-ons look bad :frowning:

1 Like

There is a similar bug in Confluence which makes me wonder if it’s a bug in the Connect framework. https://jira.atlassian.com/browse/CONFCLOUD-58565

2 Likes

A fix may have already rolled out. Just tested it on my dev instance and in both Jira and Confluence, the second iframe is no longer loading.

1 Like

In case it helps, we recently had same issue, also related with the loading of all.js file.

Following the steps here, in step 2 the example for the HBS view includes the statement to import all.js from https://ac-getting-started.atlassian.net/atlassian-connect/all.js, but loading of this file was failing, apparently due to a mismatch with the MIME type and the actual file content.

Checking on the web console of the browser while loading the JIRA page we noticed that all.js was also loading from https://connect-cdn.atl-paas.net/all.js, so using this URI in the HBS statement solved the issue.

1 Like