Atlassian Plugin SDK 8 & atlas-integration-test

I used Atlassian Plugin SDK 8 and run ‘atlas-integration-test’ command on two projects where amps=8.0.0 and amps=6.3.21 but builds has failed with the following stacktrace:

[ERROR] Plugin com.atlassian.maven.plugins:maven-amps-plugin:8.0.0 or one of its dependencies could not be resolved: Could not find artifact com.atlassian.maven.plugins:maven-amps-plugin:jar:8.0.0 in atlassian-public (https://maven.atlassian.com/repository/public) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

How to fix it?

5 Likes

I believe this is a bug with the deb install of the Atlassian SDK. If you open /usr/bin/atlas-integration-test and go to line 189 it will look like this:

MVN_COMMAND="com.atlassian.maven.plugins:maven-amps-plugin:8.0.0:integration-test"

If you change maven-amps-plugin to amps-maven-plugin this error will go away.

4 Likes

Thanks, @pbogacz, this has been raised a few days ago, kindly check ATLASSDK-161. You should try @pgesek’s suggestion since the AMPS maven plugin names have changed in version 8 (see ATLASSDK-147).

Hey guys,

Thanks for the tip, that worked well. However, now when I run atlas-integration-test the SDK doesn’t find any tests to run anymore. Have you seen this before?

Hi @vpelizza
Did you find out why the SDK doesn’t find your test and how to fix that?

Thanks

@andrey.kozinets

Yes, we have changed one line on the atlas-integration-test script file:
Replacing this:

MVN_COMMAND="com.atlassian.maven.plugins:amps-maven-plugin:8.0.0:integration-test"

…for this:

MVN_COMMAND="integration-test"

…should be enough to get it working again.

Hope that helps!

1 Like

Thanks a lot! This helped

Hi.

I’m using the SDK 8.0.7. I did these changes:

  1. Comment the line
    @rem set MVN_COMMAND=com.atlassian.maven.plugins:maven-amps-plugin:%AMPS_PLUGIN_VERSION_STRIPPED%:integration-test

  2. Add the new line changing the values maven-amps-plugin to amps-maven-plugin
    set MVN_COMMAND=com.atlassian.maven.plugins:amps-maven-plugin:%AMPS_PLUGIN_VERSION_STRIPPED%:integration-test