@atlassianlabs/jql-editor errors

Hi,

An error occurred when I try to reproduce the example from the documentation

index.es.js:525 Uncaught TypeError: Class constructor Transform cannot be invoked without 'new'
    at new Transaction (index.es.js:525:1)
    at ./node_modules/prosemirror-state/dist/index.es.js.prototypeAccessors$1.tr.get (index.es.js:875:44)
    at index.js:521:1
    at dispatch (bind-actions.js:24:1)
    at index.js:435:1
    at dispatch (bind-actions.js:24:1)
    at index.js:963:1
    at dispatch (bind-actions.js:24:1)
    at Object.onInit (bind-actions.js:41:1)
    at Container.triggerContainerAction (container.js:67:1)

The above error occurred in the <Container(jql-editor)> component:
    in Container(jql-editor) (created by JQLEditorInner)
    in JQLEditorInner (created by Context.Consumer)
    in injectIntl(JQLEditorInner) (created by Lazy(Component))
    in Lazy(Component)
    in Suspense (created by LazySuspense)
    in LazySuspense
    in Unknown
    in ErrorBoundary
    in Unknown
    in IntlProvider
    in Unknown (created by MyJQLEditor)
    in MyJQLEditor

React will try to recreate this component tree from scratch using the error boundary you provided, ErrorBoundary.

pakage.json

"dependencies": {
    "@atlassianlabs/jql-editor": "^1.1.0",
    "@atlassianlabs/jql-editor-autocomplete-rest": "^1.0.0",
    "react": "^16.14.0",
    "react-dom": "^16.14.0"
  },

  "devDependencies": {
    "@babel/core": "^7.18.10",
    "@babel/preset-env": "^7.18.10",
    "@babel/preset-react": "^7.18.6",
    "babel-loader": "^8.2.5",    
    "html-webpack-plugin": "^4.5.2",
    "webpack": "^4.44.2",
    "webpack-cli": "^4.10.0",
    "webpack-dev-server": "^4.10.0"
  },

.babelrc

{
  "presets": [
    "@babel/preset-env",
    "@babel/preset-react"
  ]
}

Please help me with bug

Best regards.

Hello @termit7000 apologies for this error you are facing. I believe this is the same issue documented here: JQLEditorConnect render error. Where there are incompatible versions being installed of the prosemirror-transform dependency.
If you specify a fixed version in your package.json, e.g. "prosemirror-transform": "1.3.2", I believe that will fix the issue.

In the meantime we’ll look to update the package to prevent this issue from recurring.

Thanks,
Kyle