Authorized users/ Grant Access to Forge App (Custom UI with Rest API Calls with "asApp")

Hi all,

i created a Forge App in the Service Desk (Costum UI + Rest API calls to Jira/Confluence with “asApp”). I installed it on the instance and I as an Admin of the instance and owner of the App I can grant Permission to Jira and Confluence via the Rest API. After this I can use the App without problems.

Problem: Each other person who wants to use the App gets a request to “Allows Access” and then if this person clicks it, there will come just an Error Message.

Grant Access Request:
Grant_Access

Error Message:

I tried already following and it was sadly not working:

  • App in Dev (Other Apps are working fine as Devs on the instance)
  • App in Prod
  • Update of the Forge CLI and increase of the version to an new mayor version

In the Atlassian Administration Page under Connected Apps i can see the app and their Permissions which are given. But as well i can see that just my own user has an authorization and I am not sure how i can add further users to it.

Does anyone has an hint where my error could be?

Thank you in advance.

Best
Maren

Hey Maren, do those users have access to Jira and Confluence sites you’ve installed the app on? Because the app has access to Jira and Confluence scopes, users will need to have access to those sites to use the app.

1 Like

Hi Adam,

thanks for your response.

Even for users which have full access to the Jira and Confluence scopes they can not give access to them selfes to use the app (including other Admins).

So just I am as a App Owner can use it. No other Admin in the Project can use the App.

Is your app installed to the corresponding Jira and Confluence sites as well?

If so would you mind sharing your app id and site you’re working with.

Additionally are the users using the app anonymous or do they Atlassian accounts?

Hi Joshua,

the problem that the user cannot grant access is solved. The issue was the following:

  • Using a computer with more than one Atlassian ID so that it was not taking the correct one automatically. For our customers who has normally just one ID it is always working.

That each person still has to grant access is still an issue. Do you know when it will be changed (Just saw it on the Roadmap).

Thank you so much for your answer.

Maren