This app requires access to a Confluence & User identity site which you don't have


One of my customers is running into a strange error when trying to approve the permissions for one of my Forge apps running on Confluence.
When they load a page referencing the app, they initially see a permissions required popup as expected.

When they click to approve the permissions, the spinner never stops spinning and a new page opens with the following error “This app requires access to a Confluence & User identity site which you don’t have or don’t have permission to access”

The user attempting to do this is an admin on their site.
I have other customers using the app with no problems.
The permissions section of my manifest.yml is as follows:

    - read:content-details:confluence
    - read:user:confluence
    - storage:app
    - write:content:confluence

The only different thing I notice about the customer is that their root url is rather than the standard
I was wondering if anyone else had run into the same issue and worked out how to fix it?



There was one person recently who had a similar problem.

Let me know if this helps.


have you been able to solve this issue? We face the same behaviour and multiple Atlassian IDs is not the cause.


same issue

I’ve got the same issue, is there any news ?

Hi all,

To make investigation faster it will be helpful to understand the similarities between these situations.

Is there a specific module that you’re using? A specific set of scopes? Are you also in a site or a site?

The error can pop up when a Jira Forge app requests Confluence scopes or vice versa. OP is not in this situation but I want to make sure none of these other cases are a result of this.

If you could also mention here or in a DM the account facing the problem and the site it’s happening on.

I just ran into the issue and it was the multiple account ids problem, even though it looked like I was only logged in as one account.

I think the problem is that the site redirects to which is a different domain and it just picks one of the accounts.

I went to Log in with Atlassian account and logged out completely, then logged back in and it worked.

1 Like

It works for me, thanks :slight_smile: