Can't install addon from ngrok


Since yesterday I have an issue with installing addon for Jira Cloud on my instance
In network stats I can see requests to GET addon descriptor, but no requests to any lifecycle endpoints.
I’m getting the below error:

[type:INSTALL, pingAfter:300, status:[done:true, statusCode:200, contentType:application/vnd.atl.plugins.task.install.err+json,, errorMessage:The app host returned HTTP response code 404 when we tried to contact it during installation. Please try again later or contact the app vendor., source:, name:], links:[self:/wiki/rest/plugins/1.0/pending/f18ddfb3-c6e0-4e6d-91ab-2fc6331a3ae6, alternate:/wiki/rest/plugins/1.0/tasks/f18ddfb3-c6e0-4e6d-91ab-2fc6331a3ae6], timestamp:1622190955300, accountId:557058:0ee6e3bd-4d3f-441e-96f7-51309122bd74, id:f18ddfb3-c6e0-4e6d-91ab-2fc6331a3ae6]
1 Like

I intermittently get SSL error. And I can install the same ngrok url in other Jira instance.

Hi, I got strange problem today also. Nothing was helping till I uninstalled the app first. After that, the installation got through.

Our App also cannot be installed from the Marketplace since yesterday for SSL issue and we have an active request - AMKTHELP-31536

I had to uninstall the app too before, after which it worked again. In case you can’t uninstall the app, try to remove the token first

I’m seeing similar issues in different instances, but with a private app from MPAC. The error message is not that helpful. Might this be related? I’m installing the app via Upload app.


This issue was raised internally and a fix has been applied.

1 Like