Eclipse maven plugin connectors


I am trying to develop a Plugin for JIRA 7.0.11 and I used the Atlassian-Tutorial resource as my guide to start with the basic. Since I wanted to develop the source logic with the help of an IDE, I used setting up Eclipse IDE link on Atlassian to establish all the libraries and repositories needed.

Step 1 - is to generate a plugin skeleton by using the atlas-create-jira-plugin command and there were no issues here.

Step 2 - involved import the project to eclipse and I have received errors ini this process.

Here is the link to the image of the errors:

I would like to know how to resolve these errors prior to moving forward. Any help or resources that point to these issues is appreciated.

Thanks in advance.!!

1 Like

Hi @rikhil.yalamanchi,

Is Eclipse using the correct Maven Settings?
Take a look here for more information around the Atlassian Maven repositories:

Hey @pvandevoorde,

I believe I used the correct settings for the Eclipse IDE. Just followed the instructions from the link and established connection.

This is the screenshot of the maven settings from my development environment.

I did find that other developers are having the same kind of issue. Please Check this link as well.

Let me know if I am doing anything wrong here.

Thank you!!

Hey @rikhil.yalamanchi,

I currently use Eclipse Neon.3 in building and testing add-ons too. For the scenario you encountered here are the steps you can do:

  1. If you’re starting from a project not yet imported to Eclipse proceed to #2, if not kindly delete that project from Eclipse but ONLY in the IDE and not the file system
  2. Using CLI, go to your project directory and call atlas-mvn eclipse:eclipse. This will create the necessary eclipse files and configure it properly.
  3. In your Eclipse import the project as General > Existing Projects into Workspace
  4. Those red X marks should be gone. I’ve tried it again just now and still works like how I described it.

Hope this helps!


I followed your procedure and it works fine now.
I am not sure what was causing the problem earlier. :wink:

Thanks for the Help!

You’re welcome @rikhil.yalamanchi. Glad to know it works for you :slight_smile: