Forge app authentication OAuth error

Hi everyone!

when we install a forge app on a Jira domain, it needs to get the permission. it shows this message:

“For this app to display, you need to allow the app to access Atlassian products on your behalf”

and you can give access to app by clicking on Allow access.

but! since two days ago, when I install my app and try to give it access, it throw me this error:

my app uses this scopes:
permissions:

  scopes:

    - 'read:jira-user'

    - 'read:jira-work'

    - 'write:jira-work'

    - 'storage:app'

    - 'manage:jira-configuration'

and again, I haven’t had this problem, suddenly it starts to give me this error and I have no idea why

I would really appreciate if anyone could help me with this.
Thanks!

2 Likes

Same issue here, I’ve just added a new scope and got this error. I’ve tried:

  • Check if all products (Jira / Confluence / Ecosystem) are up-to-date with forge install --upgrade
  • Removing the new permission + redeploy
  • Uninstall / Reinstall the app

But still the same issue.

Maybe an Atlassian issue with https://api.atlassian.com/oauth2 ?

Update:

I’ve also tried:

  • Accept permissions with another browser / incognito mode / cache cleared
  • Revoke app sharing in the Forge developer console
  • Deployed to the production environment and installed as a prod app

But nothing change. I’ve looked for discriminatory criterion, but same issue:

  • Created a new app and replaced my app ID with the new one (doesn’t seem to be linked to the app ID)
  • Update the permissions on an previous hello-world Forge app (same conclusion)
  • Create a new Jira Cloud instance (doesn’t seem to be linked to the instance)

I wondering if the problem is linked to my Atlassian account ?

2 Likes

Hey Team,

I’m following this up internally to try and get an answer here :slight_smile:

2 Likes

Thanks for your reply! I just tested again and now it’s working for me !
Still interested if you have more information (in case this issue is encountered again)

2 Likes