FYI: The Marketplace may validate your descriptor more strictly than the target Atlassian app

We recently updated our app, and the got errors from the market place about the app descriptor.
We also got weird error messages when we tried to create a new version manually.

However, we could install the app (in this case Bitbucket Cloud) just fine with plain URL to the Atlassian Connect descriptor. We where puzzled and raised support tickets.

After a some back and forth, it turned out that our descriptor was slightly wrong.
It used the module name ‘adminPage’ instead of ‘adminPages’. Bitbucket Cloud accepted that just fine and the pages worked as intended. However, the Marketplace didn’t accept that format and was more strict, creating errors and refused to take the updated app.

TLDR: If the Marketplace doesn’t take the app descriptor / complains about errors, but it is working find in the actual app: Then double check the app descriptor. The marketplace is more strict with the format the the actual app.


Hi @RomanStoffel , we mostly use the connect.json schema published via as a reference instead of the documentation when modifying an app’s descriptor.