I use command atlas-run and it error

Unresolveable build extension: Plugin com.atlassian.maven.plugins:maven-jira-plugin:6.1.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.atlassian.maven.plugins:maven-jira-plugin:jar:6.1.2: Could not transfer artifact com.atlassian.maven.plugins:maven-jira-plugin:pom:6.1.2 from/to atlassian-public (https://maven.atlassian.com/repository/public): Connection reset -> [Help 2]

Hi @321497050,

Can you please provide us with a bit more information here?
What were you trying to do?
When did this error happen?
What version of the SDK are you using?
How has your maven been set up?

Cheers,
Peter

i just want run a demo(demo download from bitbucket).

i want to use atlas-mvn eclipse:eclipse atlas-create-jira-plugin but has error

I am seeing the same thing when incrementing our Confluence app to use newer Confluence versions and datasets. Reproduced with Confluence 6.13.4 and 6.14.2:

[INFO] Starting confluence...

[INFO] Configured Artifact: com.atlassian.confluence.plugins:confluence-plugin-test-resources:6.14.2:zip

Downloading: https://maven.atlassian.com/repository/public/com/atlassian/confluence/plugins/confluence-plugin-test-resources/6.14.2/confluence-plugin-test-resources-6.14.2.zip

Apr 17, 2019 2:37:06 PM org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute

INFO: I/O exception (java.net.SocketException) caught when processing request: Connection reset

This is in an environment where everything used to work.

Edit: Figured out that if you update to the latest SDK then everything works fine. But also keep an eye out for: Getting error on `atlas-run` which hit me.

if under windows , try to put this in your browser https://maven.atlassian.com/repository/public/com/atlassian/confluence/plugins/confluence-plugin-test-resources/6.14.2/confluence-plugin-test-resources-6.14.2.zip

under lunix
wget https://maven.atlassian.com/repository/public/com/atlassian/confluence/plugins/confluence-plugin-test-resources/6.14.2/confluence-plugin-test-resources-6.14.2.zip

if does not work, you have a network problem, check firewall, or ask network admin

Yann

Yann,

Thanks for this answer… but when/if the zip downloads correctly… where do you extract it?

I’m having what seems to be a similar problem. I’m following these instructions, andwhen using the command atlas-run (with flags -e and -X for errors and debugging respectively) I’m getting a build failure. See the attached txt for detailed logs.

Edit: I can’t share the logs or c/p them because I’m a new user.