Installing production add-on after removing dev-version (or vice versa)


I noticed following issue, I run the Atlassian Connect Express framwork on my computer and it self-registers via ngrok with my jira instance. Also for production the same add-on runs on a public server (with the same add-on key.)

  1. Installing add-on in development mode in jira cloud instance (either via ACE or by passing the link)
  2. Remove said add-on
  3. Install the same add-on with different url (in this case production server) by passing the URL to jira instance.
  4. Installation fails due to an authentification problem. Authentication verification error (400): Unable to decode JWT token: Error: Signature verification failed for input: with method sha256

If we clear the table AddonSettings table on the production system we can install the add-on.
The same problem vice versa, when I remove the production installation from my jira instance and go back to my dev version, the self-registration fails with the same error. I have to reset my dev database, then it works fine.

I guess this is by design, but how can we use the same add-on key and switch between dev and production on the same jira instance?

On a second thought: Is this possibly a bug, that during a re-installation old add-on settings are not overwritten in the local add-on database?

Hi @SebastianK81,

If you’re installing different versions of your app in a given tenant, then be aware of the limitations outlined in Change notice - Changes to installation of a local app on Atlassian Cloud products.


1 Like