Internet Explorer 11 support

Hi @jcheung

We are receiving this error in Internet Explorer 11 when we use some components of atlaskit.

Object doesn't support property or method 'assign'

I’ve investigated the error details and it seems that is the Icon class. The version of the Icon is 6.5.2

We need to solve this because we uploaded the add-on to the marketplace and we have to support this version of Internet Explorer.

Thank you, Carlos.

1 Like

Thanks for the heads-up @carlos.fernandez.

cc: @ldenton

1 Like

Hi @carlos.fernandez thanks for raising this. Looking at the bundled code I can see that @atlaskit/icon includes babel-runtime/core-js/object/assign which should polyfill the Object.assign behaviour on IE 11.

I’ve loaded the icons demo in IE 11 (for @atlaskit/icon 6.5.2 and also the latest 8.0.1 version) and the icons seem to load fine for me.

Can you please try upgrading to the latest version of @atlaskit/icon and provide a demo of the issue using so I can reproduce the issue?

Demo links:


@carlos.fernandez I’ve been out sick a few days. Please let us know if @bgummer’s suggestion worked for you.

Thanks @bgummer

Hi @bgummer

I can’t use the with IE11 because it throws an error.

If I use 6.5.2 version it fails but, I tried to change the version of the @atlaskit/icon to 8.0.1 and it works, great!!!

But I’ve found another problem that it seems generated by the same thing.

I’m using @atlaskit/field-base to create custom fields formatted as the atlaskit ones, and FieldBase throws the same error in the console. I’ve searched in the FieldBase sources and I’ve found that the version 7.4.4 (latest) uses the @atlaskit/icon@6.5.2

Thanks Carlos

Hi @carlos.fernandez thanks for the field-base issue, glad to hear icon@8.0.1 is working for you. FYI is a good alternative if Codesandbox is not working on IE 11.

I’ve raise a pull request (link) to get the @atlaskit/field-base dependencies updated.


1 Like

Thank you @bgummer. I’ll be watching that pull request.